ROI analyses with fslmeants and featquery not working with fMRIPrep data due to different sizes


I am trying to run ROI analyses in FSL, but when I try to run to run Featquery, I get the error, “Error - mask size doesn’t match any of the images in the FEAT directory” and when I run fslmeants, I get, “Mask and Input volumes have different (x,y,z) size.”

I used Jeannette Mumford’s Feat workaround in order to use FSL with fMRIPrep output.

I encountered the following two resources, which were helpful but did not fully resolve my issue:

The updatefeatreg resolution described in second link works if you want to run featquery on your first-level. But I have three levels-- Runs then subjects then group. So updatefeatreg will not run for my second level.

As described by Chris in the first link, “The voxel size or FOV do not match (because FMRIPREP uses the resolution of the input images), but the locations should overlap nicely when you open the data and the atlas in Mango or FSLeyes.” My voxel size is in fact different from the mask, but they do line up well with the binarized atlas mask. But fslmeants and featquery still will not accept the mask for my fMRIPrep images.

I’m pretty stumped here. Should I warp my data to MNI_2mm? That seems unnecessary and not like the right thing to do, right?

I got an ROI to work in fslmeants by following the instructions described here of resampling the mask to the the fMRIPrep MNI152NLin2009cAsym space. Featquery still returns an error though, even with the resampled mask.

Is this the best way to get atlas structures to work with fMRIPrep output?

Have you already tried this:




Ah, I missed that. I will re-run preprocessing with fMRIPrep with that option set. Thank you.