Unusual susceptibility distortion correction for fmriprep v21.0.2?

We are seeing some strange results of the susceptibility distortion correction in fmriprep v21.0.2. It appears to stretch the brain too far in many participants, making alignment with the structural data worse. The data has A>P phase encoding direction and we use phase difference fieldmaps to do SDC. We checked the settings for the phase encoding direction in the json files (it’s set to ‘j-’. We actually ran it with ‘j’ as well but the results of that were even worse). Earlier time points of this dataset have also been processed with an older version of fmriprep (1.5.2) and that did not result in any SDC problems and led to better alignment than these results from v21.0.2. Any ideas what is happening here?

Hi,

A few questions:

  1. does this happen in all, or just some participants?
  2. have you tried the fieldmap-less method?
  3. does this error persist in v22.0.0?
  4. what scanner manufacturer do the images come from? If GE, this discussion may be useful: fMRIPrep 20.2.3 directly measured B0 map SDC correction created worse functional images
  5. are there any errors to report?
  6. are you sure that no previous derivatives from the earlier run (e.g the work directory) were used in the newer run?

Best,
Steven

Thank you for your questions, Steven! Below are the answers:

  1. More clearly in some participants than others, but visible in the vast majority
  2. Have not tried this, but will look at it in the next couple days
  3. Have not tried this yet. Do you expect it to make a difference? I don’t see major changes to the SDC from 21.0.2 to 22.0. It looks like issues with SDC are still being worked out (“For the next release, we are investigating issues with susceptibility distortion correction (SDC).”)
  4. It’s a Siemens Skyra
  5. No errors
  6. We had already removed the working directories from the processing with an earlier version

I suggest looking at the field maps and/or single band reference images; abnormalities in those can lead to strangely distorted functional runs after preprocessing.

This topic has such a case: Repeated fmriprep distortion; perhaps from susceptibility distortion, and I summarized it and a few other examples at MVPA Meanderings: troubleshooting run-level failed preprocessing.

3 Likes